floor 0.18.0
floor: ^0.18.0 copied to clipboard

Flutter Android iOS

The typesafe, reactive, and lightweight SQLite abstraction for your Flutter applications. This library is the runtime dependency.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  floor: ^0.18.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:floor/floor.dart';
263
likes
80
pub points
95%
popularity

The typesafe, reactive, and lightweight SQLite abstraction for your Flutter applications. This library is the runtime dependency.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

vitusortner.dev@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

floor_annotation, flutter, meta, path, sqflite, sqflite_common_ffi

More

Packages that depend on floor