flipper_services 0.0.1-dev.4 icon indicating copy to clipboard operation
flipper_services: ^0.0.1-dev.4 copied to clipboard

flipper models scaffold.

0
likes
20/ 130
pub points
40%
popularity

We analyzed this package 3 hours ago, and awarded it 20 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Repository URL doesn't exist.

At the time of the analysis https://github.com/yegobox/packages was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: [ +103 ms] executing: uname -m
[  +46 ms] Exit code 0 from: uname -m
[        ] x86_64
[   +7 ms] executing: [/tool/stable/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[   +7 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] 676cefaaff197f27424942307668886253e1ec35
[   +1 ms] executing: [/tool/stable/flutter/] git tag --points-at 676cefaaff197f27424942307668886253e1ec35
[  +28 ms] Exit code 0 from: git tag --points-at 676cefaaff197f27424942307668886253e1ec35
[        ] 3.0.3
[  +12 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[   +7 ms] Exit code 128 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] fatal: HEAD does not point to a branch
[  +78 ms] Unable to locate an Android SDK.
[   +5 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref HEAD
[   +7 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] HEAD
[  +75 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[...]
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[  +61 ms] executing: /tool/stable/flutter/bin/cache/dart-sdk/bin/dart __deprecated_pub upgrade --verbose
MSG : Resolving dependencies...
MSG : Logs written to /tmp/tool-envCPWROQ/pub-cache-dirABRPVF/log/pub_log.txt.
[+4620 ms] "flutter pub" took 4,785ms.
[   +3 ms] Running shutdown hooks
[        ] Shutdown hooks complete
[   +1 ms] exiting with code 1

stderr: FINE: Pub 2.17.5
SLVR: fact: flipper_services is 0.0.1-dev.4
SLVR: derived: flipper_services
SLVR: fact: flipper_services depends on bluetooth_thermal_printer ^0.0.6
SLVR: fact: flipper_services depends on cloud_firestore ^3.1.7
SLVR: fact: flipper_services depends on cron ^0.4.0
SLVR: fact: flipper_services depends on dio ^4.0.4
SLVR: fact: flipper_services depends on esc_pos_utils_plus ^2.0.1+3
SLVR: fact: flipper_services depends on extension_google_sign_in_as_googleapis_auth ^2.0.3
SLVR: fact: flipper_services depends on firebase_analytics ^8.0.3
SLVR: fact: flipper_services depends on firebase_auth ^3.3.5
SLVR: fact: flipper_services depends on firebase_crashlytics ^2.5.0
SLVR: fact: flipper_services depends on firebase_dynamic_links ^4.0.5
SLVR: fact: flipper_services depends on firebase_messaging ^11.2.3
SLVR: fact: flipper_services depends on firebase_remote_config ^2.0.0
SLVR: fact: flipper_services depends on flipper_models ^0.0.1-dev.3
SLVR: fact: flipper_services depends on flipper_routing ^0.0.1-dev.2
SLVR: fact: flipper_services depends on flipper_rw ^1.0.1-dev.2
SLVR: fact: flipper_services depends on flutter from sdk
SLVR: fact: flipper_services depends on flutter_chat_types ^3.2.0
[...]
           <asynchronous suspension>
           #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #5      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
           <asynchronous suspension>
           #6      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:281:9)
           <asynchronous suspension>
           #7      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #8      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:229:5)
           <asynchronous suspension>
           #9      run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
           <asynchronous suspension>
           #10     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #11     main (package:flutter_tools/executable.dart:94:3)
           <asynchronous suspension>



icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 1513 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:firebase_crashlytics/firebase_crashlytics.dart'.

lib/FirebaseCrashlyticService.dart:1:8

  ╷
1 │ import 'package:firebase_crashlytics/firebase_crashlytics.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/FirebaseCrashlyticService.dart

ERROR: Target of URI doesn't exist: 'package:flutter/foundation.dart'.

lib/FirebaseCrashlyticService.dart:2:8

  ╷
2 │ import 'package:flutter/foundation.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/FirebaseCrashlyticService.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because every version of flipper_rw depends on flipper_routing ^0.0.1+1 which depends on flipper_dashboard ^0.0.1, every version of flipper_rw requires flipper_dashboard ^0.0.1.
So, because no versions of flipper_dashboard match ^0.0.1 and flipper_services depends on flipper_rw ^1.0.1-dev.2, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.