flamingo 2.2.1
flamingo: ^2.2.1 copied to clipboard

This is Firebase Firestore Model Framework Library. Can be manage document reference and collection reference. And provide Firestore and Cloud Storage interface.

51
likes
100 / 130
pub points
77 %
popularity

We analyzed this package on May 12, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 24 out of 268 API elements (9.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flamingo/flamingo.dart that imports:
  • package:flamingo/src/storage.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The operand can't be null, so the condition is always true.

lib/src/collection_paging_listener.dart:58:33

   ╷
58 │         .where((event) => event != null)
   │                                 ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/collection_paging_listener.dart

INFO: The operand can't be null, so the condition is always true.

lib/src/helper/helper.dart:48:16

   ╷
48 │     if (models != null) {
   │                ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/helper/helper.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^2.0.02.1.02.1.0
firebase_core^1.1.01.1.11.1.1
firebase_storage^8.0.58.0.68.0.6
flutterflutter0.0.00.0.0
rxdart^0.26.00.26.00.27.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.6.12.6.1
characters-1.1.01.1.0
charcode-1.2.01.2.0
cloud_firestore_platform_interface-5.0.15.0.1
cloud_firestore_web-2.0.12.0.1
collection-1.15.01.15.0
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.0.31.0.3
firebase_storage_platform_interface-2.0.42.0.4
firebase_storage_web-1.0.61.0.6
flutter_web_plugins-0.0.00.0.0
http-0.13.30.13.3
http_parser-4.0.04.0.0
js-0.6.30.6.3
meta-1.3.01.3.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
plugin_platform_interface-2.0.02.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.26.0` on rxdart does not support the stable version `0.27.0`, that was published 5 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

51
likes
100
pub points
77%
popularity

Publisher

neverjp.com

This is Firebase Firestore Model Framework Library. Can be manage document reference and collection reference. And provide Firestore and Cloud Storage interface.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cloud_firestore, firebase_core, firebase_storage, flutter, rxdart

More

Packages that depend on flamingo