flame_rive 1.10.0 copy "flame_rive: ^1.10.0" to clipboard
flame_rive: ^1.10.0 copied to clipboard

Rive support for the Flame game engine. This uses the rive package and provides wrappers and components to be used inside Flame.

30
likes
140/ 140
pub points
85%
popularity

We analyzed this package 9 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

535 out of 1518 API elements (35.2 %) have documentation comments.

Some symbols that are missing documentation: flame_rive, flame_rive.Artboard, flame_rive.Artboard.Artboard, flame_rive.Artboard.activeNestedArtboards, flame_rive.Artboard.addFill.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:flame_rive/flame_rive.dart that imports:
  • package:flame_rive/src/rive_component.dart that imports:
  • package:rive/rive.dart that imports:
  • package:rive/src/runtime_nested_artboard.dart that imports:
  • package:rive_common/math.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flame ^1.16.0 1.16.0 1.16.0
flutter flutter 0.0.0 0.0.0
rive ^0.12.3 0.12.4 0.12.4
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
graphs - 2.3.1 2.3.1
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
ordered_set - 5.0.2 5.0.2
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
rive_common - 0.2.8 0.3.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

30
likes
140
pub points
85%
popularity

Publisher

verified publisherflame-engine.org

Rive support for the Flame game engine. This uses the rive package and provides wrappers and components to be used inside Flame.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

Funding

Consider supporting this project:

opencollective.com
github.com
patreon.com

License

MIT (LICENSE)

Dependencies

flame, flutter, rive

More

Packages that depend on flame_rive