firebase_dart 1.0.0-dev.27
firebase_dart: ^1.0.0-dev.27 copied to clipboard

A port of the Firebase database, auth and storage client to pure Dart code, usable on different platforms

10
likes
110 / 130
pub points
86 %
popularity

We analyzed this package on Apr 7, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 413 out of 639 API elements (64.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:firebase_dart/firebase_dart.dart that imports:
  • package:firebase_dart/implementation/pure_dart.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 45 issues. Showing the first 2:

lib/auth.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/core.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
_discoveryapis_commons^1.0.01.0.01.0.0
async^2.5.02.5.02.5.0
clock^1.1.01.1.01.1.0
collection^1.15.01.15.01.15.0
crypto^3.0.03.0.13.0.1
expressions^0.2.00.2.20.2.2
googleapis^2.0.02.0.02.0.0
googleapis_auth^1.1.01.1.01.1.0
hive^2.0.02.0.22.0.2
http^0.13.00.13.10.13.1
jose^0.3.00.3.00.3.0
logging^1.0.01.0.11.0.1
meta^1.3.01.3.01.3.0
openid_client^0.4.00.4.00.4.0
pedantic^1.11.01.11.01.11.0
quiver^3.0.03.0.13.0.1
rxdart^0.26.00.26.00.26.0
sortedmap^0.5.00.5.00.5.0
stream_channel^2.1.02.1.02.1.0
uuid^3.0.13.0.33.0.3
web_socket_channel^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.0.02.0.0
asn1lib-1.0.01.0.0
charcode-1.2.01.2.0
crypto_keys-0.2.00.2.0
http_parser-4.0.04.0.0
matcher-0.12.100.12.10
path-1.8.01.8.0
petitparser-4.1.04.1.0
pointycastle-3.0.13.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
x509-0.2.00.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Dart 2.12.2.

10
likes
110
pub points
86%
popularity

Publisher

appsup.be

A port of the Firebase database, auth and storage client to pure Dart code, usable on different platforms

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache (LICENSE)

Dependencies

_discoveryapis_commons, async, clock, collection, crypto, expressions, googleapis, googleapis_auth, hive, http, jose, logging, meta, openid_client, pedantic, quiver, rxdart, sortedmap, stream_channel, uuid, web_socket_channel

More

Packages that depend on firebase_dart