firebase_dart 1.0.0-dev.27
firebase_dart: ^1.0.0-dev.27 copied to clipboard

A port of the Firebase database, auth and storage client to pure Dart code, usable on different platforms

A pure Dart implementation of the Firebase client

Usage #

A simple usage example:

import 'package:firebase_dart/firebase_dart.dart';

main() {
  var ref = new Firebase("https://n6ufdauwqsdfmp.firebaseio-demo.com/");

  ref.child("test").onValue.listen((e) {
    print(e.snapshot.val);
  });
}

Local database #

Besides connecting to a remote firebase database, you can also create and work with a local in memory database.

var ref = new Firebase("mem://some.name/");

Features and bugs #

Please file feature requests and bugs at the issue tracker.

9
likes
110
pub points
86%
popularity

Publisher

appsup.be

A port of the Firebase database, auth and storage client to pure Dart code, usable on different platforms

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache (LICENSE)

Dependencies

_discoveryapis_commons, async, clock, collection, crypto, expressions, googleapis, googleapis_auth, hive, http, jose, logging, meta, openid_client, pedantic, quiver, rxdart, sortedmap, stream_channel, uuid, web_socket_channel

More

Packages that depend on firebase_dart