fb_image_picker 0.0.1 copy "fb_image_picker: ^0.0.1" to clipboard
fb_image_picker: ^0.0.1 copied to clipboard

FaceBook image picker.

7
likes
130/ 160
pub points
12%
popularity

We analyzed this package 42 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

16 out of 57 API elements (28.1 %) have documentation comments.

Some symbols that are missing documentation: fb_image_picker, fb_image_picker.APPFolderImageListView, fb_image_picker.APPFolderImageListView.APPFolderImageListView, fb_image_picker.APPFolderImageListView.backgroundColor, fb_image_picker.APPFolderImageListView.textStyle.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:fb_image_picker/fb_image_picker.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:fb_image_picker/fb_image_picker.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.
Package does not support platform `macOS`.

Because:

  • package:fb_image_picker/fb_image_picker.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.
Package does not support platform `Web`.

Because:

  • package:fb_image_picker/fb_image_picker.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'WillPopScope' is deprecated and shouldn't be used. Use PopScope instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/fb_image_picker.dart:300:12

    ╷
300 │     return WillPopScope(
    │            ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/fb_image_picker.dart

INFO: 'WillPopScope.new' is deprecated and shouldn't be used. Use PopScope instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/fb_image_picker.dart:300:12

    ╷
300 │     return WillPopScope(
    │            ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/fb_image_picker.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
camera ^0.9.4+16 0.9.8+1 0.11.0+1
flutter flutter 0.0.0 0.0.0
path ^1.8.0 1.9.0 1.9.0
path_provider ^2.0.9 2.1.3 2.1.3
permission_handler ^9.2.0 9.2.0 11.3.1
skeleton_animation ^0.1.4 0.1.4 0.1.4
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
camera_android - 0.9.8+3 0.10.9+8
camera_avfoundation - 0.9.17+1 0.9.17+1
camera_platform_interface - 2.8.0 2.8.0
camera_web - 0.2.1+6 0.3.4
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
cross_file - 0.3.4+1 0.3.4+1
ffi - 2.1.2 2.1.2
flutter_plugin_android_lifecycle - 2.0.20 2.0.20
flutter_web_plugins - 0.0.0 0.0.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path_provider_android - 2.2.7 2.2.7
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
permission_handler_android - 9.0.2+1 12.0.7
permission_handler_apple - 9.1.4 9.4.5
permission_handler_platform_interface - 3.12.0 4.2.1
permission_handler_windows - 0.1.3 0.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
quiver - 3.2.1 3.2.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.3
vector_math - 2.1.4 2.1.4
web - 0.5.1 1.0.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.9.4+16` on camera does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions camera to update the constraint.

The constraint `^9.2.0` on permission_handler does not support the stable version `10.0.0`.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.