fast_flutter_driver_tool 2.0.0+1
fast_flutter_driver_tool: ^2.0.0+1 copied to clipboard

Toolkit for running rapidly flutter driver tests on desktop.

7
likes
120 / 130
pub points
60 %
popularity

We analyzed this package on Jun 18, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 32 out of 97 API elements (33.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:fast_flutter_driver_tool/fast_flutter_driver_tool.dart that imports:
  • package:fast_flutter_driver_tool/src/utils/system.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.0.02.1.12.1.1
cli_util^0.3.00.3.00.3.0
http^0.13.00.13.30.13.3
meta^1.3.01.4.01.4.0
path^1.8.01.8.01.8.0
process_run^0.12.00.12.10.12.1
yaml^3.1.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.7.02.7.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-4.0.04.0.0
pedantic-1.11.11.11.1
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.18.2, Dart 2.13.3.

7
likes
120
pub points
60%
popularity

Publisher

tomek-polanski.com

Toolkit for running rapidly flutter driver tests on desktop.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

args, cli_util, http, meta, path, process_run, yaml

More

Packages that depend on fast_flutter_driver_tool