fast_flutter_driver_tool 0.0.5

  • Readme
  • Changelog
  • Example
  • Installing
  • new70

Fast Flutter Driver Tool #

Part of fast_flutter_driver. This is the command line tool for running flutter driver. An example on how to use this tool can be found in the example.

0.0.5 #

  • Returning error code when tests fail

0.0.4+1 #

  • Release cleanup

0.0.4 #

  • Making logging less verbose (#15)
  • Not needing to create generic_test.dart file (#14)
  • Removing not needed dependencies

0.0.3 #

  • Improving logging

0.0.2 #

  • Updating package setup

0.0.1 #

  • Initial version

example/README.md

Fast Flutter Driver Tool Example #

The example on how to use this library can be found in the example.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate fast_flutter_driver_tool

2. Use it

The package has the following executables:


$ fastdriver

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fast_flutter_driver_tool: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fast_flutter_driver_tool/fast_flutter_driver_tool.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
45
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Jan 17, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Health issues and suggestions

Document public APIs. (-1 points)

31 out of 31 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
args ^1.5.1 1.5.2
cli_util ^0.1.3+2 0.1.3+2
colorize ^2.0.0 2.0.0
meta ^1.1.8 1.1.8
process_run ^0.10.0+1 0.10.6+1
Transitive dependencies
charcode 1.1.2
collection 1.14.12
io 0.3.3
path 1.6.4
pub_semver 1.4.2
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
yaml 2.2.0