fast_flutter_driver 3.0.0+1
fast_flutter_driver: ^3.0.0+1 copied to clipboard

Toolkit for running rapidly flutter driver tests on desktop.

8
likes
90/ 130
pub points
57%
popularity

We analyzed this package on Oct 18, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 18 API elements (27.8 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Android`.

Because:

  • package:fast_flutter_driver/driver.dart that declares support for platforms: macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/window_utils/window_utils.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.0.02.3.02.3.0
bitsdojo_window^0.1.00.1.1+10.1.1+1
fast_flutter_driver_tool^2.0.02.0.0+13.0.0
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
bitsdojo_window_linux-0.1.10.1.1
bitsdojo_window_macos-0.1.00.1.0
bitsdojo_window_platform_interface-0.1.00.1.0
bitsdojo_window_windows-0.1.00.1.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
collection-1.15.01.15.0
ffi-1.1.21.1.2
http-0.13.40.13.4
http_parser-4.0.04.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
plugin_platform_interface-2.0.22.0.2
process_run-0.12.2+20.12.2+2
pub_semver-2.1.02.1.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.92.2.9
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on fast_flutter_driver_tool does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions fast_flutter_driver_tool to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.