fair_pushy 0.0.1 copy "fair_pushy: ^0.0.1" to clipboard
fair_pushy: ^0.0.1 copied to clipboard

fair_pushy is a hot update sdk for fair

1
likes
95/ 140
pub points
0%
popularity

We analyzed this package 6 days ago, and awarded it 95 pub points (of a possible 140):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

8 out of 30 API elements (26.7 %) have documentation comments.

Some symbols that are missing documentation: fair_pushy, fair_pushy.FairPushy, fair_pushy.FairPushy.FairPushy, fair_pushy.FairPushy.registerPageBuilder, fair_pushy.FairPushy.registerPlaceholderBuilder.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:fair_pushy/fair_pushy.dart that imports:
  • package:fair_pushy/src/delegate.dart that imports:
  • package:fair_pushy/src/http/utils/http_client.dart that imports:
  • package:fair_pushy/src/http/utils/permission_utils.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:fair_pushy/fair_pushy.dart that imports:
  • package:fair_pushy/src/delegate.dart that imports:
  • package:fair_pushy/src/http/utils/http_client.dart that imports:
  • package:fair_pushy/src/http/utils/permission_utils.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:fair_pushy/fair_pushy.dart that imports:
  • package:fair_pushy/src/delegate.dart that imports:
  • package:fair_pushy/src/http/utils/http_client.dart that imports:
  • package:fair_pushy/src/http/utils/permission_utils.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:fair_pushy/fair_pushy.dart that imports:
  • package:fair_pushy/src/delegate.dart that imports:
  • package:fair_pushy/src/files/archive_tools.dart that imports:
  • package:fair_pushy/src/files/fair_file.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

WARNING: The receiver can't be null, so the null-aware operator '?.' is unnecessary.

lib/src/widget/toast.dart:20:19

   ╷
20 │       overlayState?.insert(_overlayEntry!);
   │                   ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widget/toast.dart

INFO: The type of the right operand ('PermissionStatus') isn't a subtype or a supertype of the left operand ('ServiceStatus').

lib/src/http/utils/permission_utils.dart:18:31

   ╷
18 │     if (ServiceStatus.enabled == serviceStatus) {
   │                               ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/http/utils/permission_utils.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
archive ^3.3.0 3.4.10 3.4.10
dio ^4.0.6 4.0.6 5.4.1
flutter flutter 0.0.0 0.0.0
path_provider ^2.0.4 2.1.2 2.1.2
permission_handler ^6.0.1 6.1.3 11.3.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
permission_handler_platform_interface - 3.12.0 4.2.0
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.7.4 3.7.4
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.6` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^6.0.1` on permission_handler does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

1
likes
95
pub points
0%
popularity

Publisher

unverified uploader

fair_pushy is a hot update sdk for fair

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

archive, dio, flutter, path_provider, permission_handler

More

Packages that depend on fair_pushy