exwidgets 2.0.1+2

  • README.md
  • changelog.md
  • Installing
  • Versions
  • 59

monitor_nav

1.0.1 #

  • 3 New Screens Added

    • Profile 2
    • Login 2
    • Payment Success
  • Minor Bug Fixes

1.0.0 #

  • Initial(Early) Release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  exwidgets: ^2.0.1+2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:exwidgets/core.dart';
import 'package:exwidgets/demo.dart';
import 'package:exwidgets/main.dart';
  
Version Uploaded Documentation Archive
2.0.8+2 Dec 18, 2018 Go to the documentation of exwidgets 2.0.8+2 Download exwidgets 2.0.8+2 archive
2.0.7+2 Dec 17, 2018 Go to the documentation of exwidgets 2.0.7+2 Download exwidgets 2.0.7+2 archive
2.0.6+2 Dec 17, 2018 Go to the documentation of exwidgets 2.0.6+2 Download exwidgets 2.0.6+2 archive
2.0.5+2 Dec 15, 2018 Go to the documentation of exwidgets 2.0.5+2 Download exwidgets 2.0.5+2 archive
2.0.4+2 Dec 15, 2018 Go to the documentation of exwidgets 2.0.4+2 Download exwidgets 2.0.4+2 archive
2.0.3+2 Dec 15, 2018 Go to the documentation of exwidgets 2.0.3+2 Download exwidgets 2.0.3+2 archive
2.0.2+2 Dec 15, 2018 Go to the documentation of exwidgets 2.0.2+2 Download exwidgets 2.0.2+2 archive
2.0.1+2 Dec 14, 2018 Go to the documentation of exwidgets 2.0.1+2 Download exwidgets 2.0.1+2 archive
2.0.0+2 Dec 14, 2018 Go to the documentation of exwidgets 2.0.0+2 Download exwidgets 2.0.0+2 archive
1.0.20+2 Dec 14, 2018 Go to the documentation of exwidgets 1.0.20+2 Download exwidgets 1.0.20+2 archive

All 29 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
94
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
68
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on May 30, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.17
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/helper/http_config.dart. (-1.99 points)

Analysis of lib/src/helper/http_config.dart reported 4 hints:

line 13 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 36 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 59 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 87 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/src/etc/firebase_lib.dart. (-1 points)

Analysis of lib/src/etc/firebase_lib.dart reported 2 hints:

line 89 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 100 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/src/form_element/google_place_autocomplete/api.dart. (-1 points)

Analysis of lib/src/form_element/google_place_autocomplete/api.dart reported 2 hints:

line 9 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 31 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix additional 19 files with analysis or formatting issues. (-2.50 points)

Additional issues in the following files:

  • lib/src/etc/firestorage_uploader.dart (1 hint)
  • lib/src/form_element/image_uploader/ex_image_uploader.dart (1 hint)
  • lib/src/helper/ex_dialog.dart (1 hint)
  • lib/src/helper/msg.dart (1 hint)
  • lib/src/helper/nav.dart (1 hint)
  • lib/core.dart (Run flutter format to format lib/core.dart.)
  • lib/demo.dart (Run flutter format to format lib/demo.dart.)
  • lib/src/etc/autofilldata.dart (Run flutter format to format lib/src/etc/autofilldata.dart.)
  • lib/src/etc/exconfig.dart (Run flutter format to format lib/src/etc/exconfig.dart.)
  • lib/src/form_element/chip_input/listview.dart (Run flutter format to format lib/src/form_element/chip_input/listview.dart.)
  • lib/src/form_element/ex_image.dart (Run flutter format to format lib/src/form_element/ex_image.dart.)
  • lib/src/form_element/extreme_loader/ex_loader.dart (Run flutter format to format lib/src/form_element/extreme_loader/ex_loader.dart.)
  • lib/src/form_element/google_place_autocomplete/ex_location_picker.dart (Run flutter format to format lib/src/form_element/google_place_autocomplete/ex_location_picker.dart.)
  • lib/src/form_element/google_place_autocomplete/mapview.dart (Run flutter format to format lib/src/form_element/google_place_autocomplete/mapview.dart.)
  • lib/src/form_element/google_place_autocomplete/model.dart (Run flutter format to format lib/src/form_element/google_place_autocomplete/model.dart.)
  • lib/src/helper/action_manager.dart (Run flutter format to format lib/src/helper/action_manager.dart.)
  • lib/src/helper/ex_instance_manager.dart (Run flutter format to format lib/src/helper/ex_instance_manager.dart.)
  • lib/src/helper/exception_handler.dart (Run flutter format to format lib/src/helper/exception_handler.dart.)
  • lib/src/helper/extreme_api.dart (Run flutter format to format lib/src/helper/extreme_api.dart.)

Maintenance issues and suggestions

Homepage URL isn't helpful. (-10 points)

Update the homepage field from pubspec.yaml: link to a website about the package or use the source repository URL.

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and exwidgets.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.47.0 <3.0.0
cloud_firestore ^0.8.2+2 0.8.2+3 0.12.0+2
cupertino_icons ^0.1.2 0.1.2
firebase_auth ^0.6.6 0.6.6 0.11.1+3
firebase_core ^0.2.5+1 0.2.5+1 0.4.0+1
firebase_messaging ^2.1.0 2.2.0+1 5.0.1+1
firebase_storage ^1.0.4 1.1.0+1 3.0.0
flutter 0.0.0
flutter_local_notifications ^0.4.2 0.4.5 0.7.1+1
flutter_localizations 0.0.0
flutter_masked_text ^0.7.0 0.7.0 0.8.0
font_awesome_flutter ^8.2.0 8.4.0
geolocator ^2.1.0 2.1.1 5.0.0
google_maps_flutter ^0.0.1 0.0.3+3 0.5.14+1
google_sign_in ^3.2.4 3.3.0+1 4.0.1+3
http ^0.12.0 0.12.0+2
image_picker ^0.4.10 0.4.12+1 0.6.0+8
intl ^0.15.7 0.15.8
path_provider ^0.4.1 0.4.1 1.1.0
rxdart ^0.19.0 0.19.0 0.22.0
sqflite ^0.12.2+1 0.12.2+1 1.1.5
url_launcher ^4.0.1 4.2.0+3 5.0.2
uuid ^1.0.3 1.0.3 2.0.1
Transitive dependencies
async 2.2.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
google_api_availability 1.0.6+1 2.0.1
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
pedantic 1.7.0
permission_handler 2.2.0 3.1.0
platform 2.2.0
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.4
synchronized 2.1.0
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
random_pk any