exwidgets 2.0.8+2

  • Readme
  • Changelog
  • Installing
  • 0


1.0.1 #

  • 3 New Screens Added

    • Profile 2
    • Login 2
    • Payment Success
  • Minor Bug Fixes

1.0.0 #

  • Initial(Early) Release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  exwidgets: ^2.0.8+2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:exwidgets/core.dart';
import 'package:exwidgets/demo.dart';
import 'package:exwidgets/main.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: Because exwidgets depends on flutter_localizations any from sdk which depends on intl 0.16.0, intl 0.16.0 is required.
 So, because exwidgets depends on intl ^0.15.7, version solving failed.

Health suggestions

Format lib/core.dart.

Run flutter format to format lib/core.dart.

Format lib/demo.dart.

Run flutter format to format lib/demo.dart.

Format lib/src/etc/autofilldata.dart.

Run flutter format to format lib/src/etc/autofilldata.dart.

Fix additional 15 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/etc/exconfig.dart (Run flutter format to format lib/src/etc/exconfig.dart.)
  • lib/src/form_element/chip_input/listview.dart (Run flutter format to format lib/src/form_element/chip_input/listview.dart.)
  • lib/src/form_element/ex_image.dart (Run flutter format to format lib/src/form_element/ex_image.dart.)
  • lib/src/form_element/ex_input.dart (Run flutter format to format lib/src/form_element/ex_input.dart.)
  • lib/src/form_element/extreme_loader/ex_loader.dart (Run flutter format to format lib/src/form_element/extreme_loader/ex_loader.dart.)
  • lib/src/form_element/google_place_autocomplete/ex_location_picker.dart (Run flutter format to format lib/src/form_element/google_place_autocomplete/ex_location_picker.dart.)
  • lib/src/form_element/google_place_autocomplete/listview.dart (Run flutter format to format lib/src/form_element/google_place_autocomplete/listview.dart.)
  • lib/src/form_element/google_place_autocomplete/mapview.dart (Run flutter format to format lib/src/form_element/google_place_autocomplete/mapview.dart.)
  • lib/src/form_element/google_place_autocomplete/model.dart (Run flutter format to format lib/src/form_element/google_place_autocomplete/model.dart.)
  • lib/src/helper/action_manager.dart (Run flutter format to format lib/src/helper/action_manager.dart.)
  • lib/src/helper/ex_dialog.dart (Run flutter format to format lib/src/helper/ex_dialog.dart.)
  • lib/src/helper/exception_handler.dart (Run flutter format to format lib/src/helper/exception_handler.dart.)
  • lib/src/helper/extreme_api.dart (Run flutter format to format lib/src/helper/extreme_api.dart.)
  • lib/src/helper/http_config.dart (Run flutter format to format lib/src/helper/http_config.dart.)
  • lib/src/helper/msg.dart (Run flutter format to format lib/src/helper/msg.dart.)

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://anagatadev.com/extreme-widget/ was unreachable.

Package is getting outdated. (-29.32 points)

The package was last published 67 weeks ago.

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and exwidgets.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.47.0 <3.0.0