ext_video_player 0.0.6
ext_video_player: ^0.0.6 copied to clipboard

Flutter plugin for displaying inline with other Flutter widgets on Android and iOS. This plugin also supports playing youtube videos & RTMP Streams

56
likes
100/ 130
pub points
86%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 72 out of 75 API elements (96.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:ext_video_player/ext_video_player.dart that declares support for platforms: Android, iOS, Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.12.20.12.20.13.3
meta^1.0.51.7.01.7.0
video_player_platform_interface^2.2.02.2.04.2.0
video_player_web>=0.1.4 <2.0.00.1.4+12.0.4
youtube_explode_dart^1.7.51.8.01.10.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
csslib-0.16.20.17.0
equatable-1.2.62.0.3
flutter_web_plugins-0.0.00.0.0
html-0.14.0+40.15.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
json_annotation-3.1.14.1.0
path-1.8.01.8.0
petitparser-3.1.04.3.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
xml-4.5.15.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.12.2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^2.2.0` on video_player_platform_interface does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions video_player_platform_interface to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

56
likes
100
pub points
86%
popularity

Publisher

karthikponnam.dev

Flutter plugin for displaying inline with other Flutter widgets on Android and iOS. This plugin also supports playing youtube videos & RTMP Streams

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, http, meta, video_player_platform_interface, video_player_web, youtube_explode_dart

More

Packages that depend on ext_video_player