es_compression_grpc 0.9.1
es_compression_grpc: ^0.9.1 copied to clipboard

gRPC compression support for Brotli, Lz4, and Zstd (Zstandard) using the es_compression Dart library

3
likes
120 / 130
pub points
0 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 19 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:es_compression_grpc/es_compression_grpc.dart that imports:
  • package:es_compression_grpc/src/zstd/codec.dart that imports:
  • package:grpc/grpc.dart that imports:
  • package:grpc/src/shared/streams.dart that imports:
  • package:http2/transport.dart that imports:
  • package:http2/src/hpack/hpack.dart that imports:
  • package:http2/src/hpack/huffman_table.dart that imports:
  • package:http2/src/hpack/huffman.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
es_compression^2.0.02.0.32.0.3
grpc^3.0.03.0.03.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.23.1.2
args-2.2.02.2.0
async-2.8.12.8.1
charcode-1.3.11.3.1
crypto-3.0.13.0.1
ffi-1.1.21.1.2
fixnum-1.0.01.0.0
googleapis_auth-1.1.01.1.0
http-0.13.30.13.3
http2-2.0.02.0.0
http_parser-4.0.04.0.0
meta-1.7.01.7.0
protobuf-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Dart 2.13.4.

3
likes
120
pub points
0%
popularity

Publisher

instantiations.com

gRPC compression support for Brotli, Lz4, and Zstd (Zstandard) using the es_compression Dart library

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

es_compression, grpc

More

Packages that depend on es_compression_grpc