enough_html_editor 0.0.5 copy "enough_html_editor: ^0.0.5" to clipboard
enough_html_editor: ^0.0.5 copied to clipboard

Slim HTML editor for Flutter with full API control and optional Flutter-based widget controls.

11
likes
120/ 140
pub points
49%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MPL-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2247 out of 4912 API elements (45.7 %) have documentation comments.

Some symbols that are missing documentation: enough_html_editor.ASN1DERDecoder, enough_html_editor.ASN1DERDecoder.ASN1DERDecoder, enough_html_editor.ASN1DERDecoder.decode, enough_html_editor.ASN1DERDecoder.getContentLength, enough_html_editor.ASN1DERDecoder.loadSubContent.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:enough_html_editor/enough_html_editor.dart that imports:
  • package:enough_html_editor/src/models.dart that imports:
  • package:enough_html_editor/src/editor_api.dart that imports:
  • package:enough_html_editor/src/editor.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:enough_html_editor/enough_html_editor.dart that imports:
  • package:enough_html_editor/src/models.dart that imports:
  • package:enough_html_editor/src/editor_api.dart that imports:
  • package:enough_html_editor/src/editor.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:enough_html_editor/enough_html_editor.dart that imports:
  • package:enough_html_editor/src/models.dart that imports:
  • package:enough_html_editor/src/editor_api.dart that imports:
  • package:enough_html_editor/src/editor.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:enough_html_editor/enough_html_editor.dart that imports:
  • package:enough_html_editor/src/models.dart that imports:
  • package:enough_html_editor/src/editor_api.dart that imports:
  • package:enough_html_editor/src/editor.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/src/controls/controls.dart:1:1

  ╷
1 │ /// All controls for the `HtmlEditor` widget.
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/controls/controls.dart

INFO: A value for optional parameter 'height' isn't ever given.

lib/src/controls/sliver.dart:58:10

   ╷
58 │     this.height = 48,
   │          ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/controls/sliver.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
enough_platform_widgets ^0.3.0 0.3.0 1.1.0
flutter flutter 0.0.0 0.0.0
flutter_colorpicker ^1.0.3 1.0.3 1.0.3
flutter_inappwebview ^5.4.3+7 5.8.0 6.0.0
image ^3.1.3 3.3.0 4.1.7
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
cupertino_icons - 1.0.8 1.0.8
cupertino_list_tile - 0.2.1+1 0.2.1+1
cupertino_progress_bar - 0.2.0 0.2.0
cupertino_stepper - 0.2.1 0.2.1
flutter_platform_widgets - 1.20.0 6.1.0
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
pointycastle - 3.9.0 3.9.0
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.3.0` on enough_platform_widgets does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions enough_platform_widgets to update the constraint.

The constraint `^5.4.3+7` on flutter_inappwebview does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions flutter_inappwebview to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

11
likes
120
pub points
49%
popularity

Publisher

verified publisherenough.de

Slim HTML editor for Flutter with full API control and optional Flutter-based widget controls.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MPL-2.0 (LICENSE)

Dependencies

enough_platform_widgets, flutter, flutter_colorpicker, flutter_inappwebview, image

More

Packages that depend on enough_html_editor