enough_giphy_flutter 0.4.1 copy "enough_giphy_flutter: ^0.4.1" to clipboard
enough_giphy_flutter: ^0.4.1 copied to clipboard

Add a powerful and customizable GIPHY picker into your Flutter app.

17
likes
120/ 140
pub points
92%
popularity

We analyzed this package 5 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MPL-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

329 out of 331 API elements (99.4 %) have documentation comments.

Some symbols that are missing documentation: enough_giphy_flutter, enough_giphy_widgets.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/enough_giphy_flutter.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
enough_giphy ^0.2.1 0.2.1 0.2.1
enough_platform_widgets ^0.7.3 0.7.4 1.1.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
cupertino_icons - 1.0.8 1.0.8
cupertino_progress_bar - 0.2.0 0.2.0
cupertino_stepper - 0.2.1 0.2.1
flutter_platform_widgets - 3.3.5 6.1.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.7.3` on enough_platform_widgets does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions enough_platform_widgets to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

17
likes
120
pub points
92%
popularity

Publisher

verified publisherenough.de

Add a powerful and customizable GIPHY picker into your Flutter app.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MPL-2.0 (LICENSE)

Dependencies

enough_giphy, enough_platform_widgets, flutter

More

Packages that depend on enough_giphy_flutter