enough_coi 0.0.6
enough_coi: ^0.0.6 copied to clipboard

unlisted

Experimental client for COI apps. [COI](https://coi-dev.org) is a server and client standard for messaging based on email.

0
likes
50 / 130
pub points
0 %
popularity

We analyzed this package on May 9, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/enough_coi_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 30 out of 398 API elements (7.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:enough_coi/enough_coi.dart that imports:
  • package:enough_coi/mail_helper.dart that imports:
  • package:enough_coi/src/http_client_helper.dart that imports:
  • dart:io
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 36 issues. Showing the first 2:

ERROR: The name 'ClientConfig' is defined in the libraries 'package:enough_coi/mail_server_config.dart (via package:enough_coi/enough_coi.dart)' and 'package:enough_mail/discover/client_config.dart (via package:enough_mail/enough_mail.dart)'.

lib/coi_client.dart:64:10

   ╷
64 │   Future<ClientConfig> discover(String emailAddress,
   │          ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/coi_client.dart

ERROR: The name 'SocketType' is defined in the libraries 'package:enough_coi/mail_server_config.dart (via package:enough_coi/enough_coi.dart)' and 'package:enough_mail/discover/client_config.dart (via package:enough_mail/enough_mail.dart)'.

lib/coi_client.dart:71:57

   ╷
71 │         config.preferredIncomingImapServer.socketType = SocketType.ssl;
   │                                                         ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/coi_client.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
basic_utils^2.4.72.7.13.0.2
enough_mail^0.0.50.0.331.2.2
event_bus^1.1.01.1.12.0.0
json_annotation^3.0.13.1.14.0.1
objectdb^1.0.7+11.2.11.2.1
uuid^2.0.42.2.23.0.4
xml^3.7.03.7.05.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
deeply-1.2.0+11.2.0+1
execution_queue-1.2.01.2.0
http-0.12.20.13.3
http_parser-3.1.44.0.0
intl-0.16.10.17.0
logging-0.11.41.0.1
meta-1.3.01.3.0
objectid-2.0.02.0.0
path-1.8.01.8.0
petitparser-3.1.04.1.0
pointycastle-2.0.13.0.1
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^2.4.7` on basic_utils does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions basic_utils to update the constraint.

The constraint `^0.0.5` on enough_mail does not support the stable version `0.1.0`.

Try running dart pub upgrade --major-versions enough_mail to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
50
pub points
0%
popularity

Publisher

enough.de

Experimental client for COI apps. [COI](https://coi-dev.org) is a server and client standard for messaging based on email.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MPL 2.0 (LICENSE)

Dependencies

basic_utils, enough_mail, event_bus, json_annotation, objectdb, uuid, xml

More

Packages that depend on enough_coi