encrypt 5.0.0
encrypt: ^5.0.0 copied to clipboard

A set of high-level APIs over PointyCastle for two-way cryptography.

202
likes
130 / 130
pub points
98 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 43 out of 112 API elements (38.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.0.02.0.02.0.0
asn1lib^1.0.01.0.01.0.0
clock^1.1.01.1.01.1.0
collection^1.15.01.15.01.15.0
crypto^3.0.03.0.13.0.1
pointycastle^3.0.13.0.13.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Dart 2.12.2.

202
likes
130
pub points
98%
popularity

A set of high-level APIs over PointyCastle for two-way cryptography.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

lc@leocavalcante.com

License

BSD (LICENSE)

Dependencies

args, asn1lib, clock, collection, crypto, pointycastle

More

Packages that depend on encrypt