encrypt 5.0.0
encrypt: ^5.0.0 copied to clipboard

A set of high-level APIs over PointyCastle for two-way cryptography.

Use this package as an executable

1. Install it

You can install the package from the command line:

$ dart pub global activate encrypt

Use it

The package has the following executables:

$ secure-random

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add encrypt

With Flutter:

 $ flutter pub pub add encrypt

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  encrypt: ^5.0.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:encrypt/encrypt.dart';
202
likes
130
pub points
98%
popularity

A set of high-level APIs over PointyCastle for two-way cryptography.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

lc@leocavalcante.com

License

BSD (LICENSE)

Dependencies

args, asn1lib, clock, collection, crypto, pointycastle

More

Packages that depend on encrypt