durt 0.1.6 icon indicating copy to clipboard operation
durt: ^0.1.6 copied to clipboard

Dart lib for duniter cryptography, useful to integrate Ğ1 libre currency to your app

1
likes
120/ 140
pub points
50%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 26 out of 51 API elements (51.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bip32_ed25519^0.2.10.2.20.5.0
bip39_multi_nullsafety^1.0.71.0.71.0.7
collection^1.15.01.17.11.17.1
fast_base58^0.2.10.2.10.2.1
graphql^5.0.05.1.35.1.3
hex^0.2.00.2.00.2.0
pinenacl^0.3.30.3.40.5.1
pointycastle^3.4.03.6.23.6.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
convert-3.1.13.1.1
crypto-3.0.23.0.2
gql-0.14.00.14.0
gql_dedupe_link-2.0.3+12.0.3+1
gql_error_link-0.2.3+10.2.3+1
gql_exec-0.4.30.4.3
gql_http_link-0.4.50.4.5
gql_link-0.5.10.5.1
gql_transform_link-0.2.2+10.2.2+1
hive-2.2.32.2.3
http-0.13.50.13.5
http_parser-4.0.24.0.2
js-0.6.70.6.7
meta-1.9.01.9.0
normalize-0.7.20.8.0
path-1.8.31.8.3
rxdart-0.27.70.27.7
source_span-1.9.11.9.1
stream_channel-2.1.12.1.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uuid-3.0.73.0.7
web_socket_channel-2.2.02.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.2.1` on bip32_ed25519 does not support the stable version `0.3.1`.

Try running dart pub upgrade --major-versions bip32_ed25519 to update the constraint.

The constraint `^0.3.3` on pinenacl does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions pinenacl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.1.

1
likes
120
pub points
50%
popularity

Publisher

verified publisher iconaxiom-team.fr

Dart lib for duniter cryptography, useful to integrate Ğ1 libre currency to your app

Homepage

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

bip32_ed25519, bip39_multi_nullsafety, collection, fast_base58, graphql, hex, pinenacl, pointycastle

More

Packages that depend on durt