dpm 0.2.3
dpm: ^0.2.3 copied to clipboard

Run commands upon installing & upgrades packages, powerfull package management with CLI. Flutter cappatible!

0
likes
90/ 130
pub points
0%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 16 out of 65 API elements (24.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dpm/dpm.dart that imports:
  • package:dpm/src/run.dart that imports:
  • package:pubspec/pubspec.dart that imports:
  • package:pubspec/src/pubspec.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.21.6.02.3.0
console^3.1.03.1.04.1.0
http^0.12.0+20.12.20.13.3
meta^1.1.71.7.01.7.0
path^1.6.21.8.01.8.0
pub_semver^1.4.21.4.42.1.0
pubspec^0.1.20.1.52.0.1
register^1.0.01.0.11.0.1
tuple^1.0.21.0.32.0.0
yaml^2.1.162.2.13.1.0
yamlicious^0.1.00.1.00.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
matcher-0.12.110.12.11
quiver-2.1.53.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uri-0.11.41.0.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^1.5.2` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^3.1.0` on console does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions console to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0-dev.0.5 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.20.0, Dart 2.14.0.

0
likes
90
pub points
0%
popularity

Publisher

serge.software

Run commands upon installing & upgrades packages, powerfull package management with CLI. Flutter cappatible!

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, console, http, meta, path, pub_semver, pubspec, register, tuple, yaml, yamlicious

More

Packages that depend on dpm