dpm 0.2.3

Dart native
Flutter Android iOS

Run commands upon installing & upgrades packages, powerfull package management with CLI. Flutter cappatible!

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate dpm

2. Use it

The package has the following executables:

$ dpm

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  dpm: ^0.2.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dpm/dpm.dart';
1
likes
100
pub points
13%
popularity

Publisher

serge.software

Run commands upon installing & upgrades packages, powerfull package management with CLI. Flutter cappatible!

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, console, http, meta, path, pub_semver, pubspec, register, tuple, yaml, yamlicious

More

Packages that depend on dpm