document_scanner_flutter 0.2.5
document_scanner_flutter: ^0.2.5 copied to clipboard

A android & ios document scanner & auto detector plugin for flutter.

27
likes
110/ 130
pub points
78%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 34 API elements (23.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:document_scanner_flutter/document_scanner_flutter.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
path_provider^2.0.22.0.52.0.5
pdf^3.4.03.6.13.6.1
photo_view^0.11.10.11.10.13.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.63.1.6
barcode-2.1.02.1.0
characters-1.1.01.2.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
image-3.0.83.0.8
meta-1.7.01.7.0
path-1.8.01.8.0
path_parsing-0.2.10.2.1
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
petitparser-4.4.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
qr-2.1.02.1.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.11.1` on photo_view does not support the stable version `0.12.0`.

Try running dart pub upgrade --major-versions photo_view to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

27
likes
110
pub points
78%
popularity

Publisher

ishaqhassan.com

A android & ios document scanner & auto detector plugin for flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, path_provider, pdf, photo_view

More

Packages that depend on document_scanner_flutter