dio_cache_interceptor_sembast_storage 0.2.0 copy "dio_cache_interceptor_sembast_storage: ^0.2.0" to clipboard
dio_cache_interceptor_sembast_storage: ^0.2.0 copied to clipboard

A DB cache store implementation with Sembast for dio_cache_interceptor package.

0
likes
130/ 140
pub points
70%
popularity

We analyzed this package 8 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

12 out of 19 API elements (63.2 %) have documentation comments.

Some symbols that are missing documentation: dio_cache_interceptor_sembast_storage, dio_cache_interceptor_sembast_storage.CacheControlExt, dio_cache_interceptor_sembast_storage.CacheControlExt.fromJson, dio_cache_interceptor_sembast_storage.CacheControlExt.toJson, dio_cache_interceptor_sembast_storage.CacheResponseExt.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio_cache_interceptor ^3.4.4 3.5.0 3.5.0
flat_buffers ^2.0.5 2.0.5 23.5.26
sembast ^3.4.3 3.6.0 3.6.0
sembast_web ^2.1.2 2.2.0 2.2.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
dio - 5.4.1 5.4.1
fixnum - 1.1.0 1.1.0
http_parser - 4.0.2 4.0.2
idb_shim - 2.3.2 2.3.2
js - 0.7.1 0.7.1
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.3.3 4.3.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.5` on flat_buffers does not support the stable version `23.5.26`.

Try running dart pub upgrade --major-versions flat_buffers to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

0
likes
130
pub points
70%
popularity

Publisher

verified publisheropenapi4j.org

A DB cache store implementation with Sembast for dio_cache_interceptor package.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

dio_cache_interceptor, flat_buffers, sembast, sembast_web

More

Packages that depend on dio_cache_interceptor_sembast_storage