devilf_engine 0.1.0
devilf_engine: ^0.1.0 copied to clipboard

A Flutter 2D RPG Game Engine On Web & Android & IOS.

0
likes
100/ 130
pub points
28%
popularity

We analyzed this package on Dec 1, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 134 out of 676 API elements (19.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 22 issues. Showing the first 2:

lib/core/df_circle.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/core/df_living.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
audioplayers^0.20.10.20.10.20.1
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

0
likes
100
pub points
28%
popularity

Publisher

ymbok.com

A Flutter 2D RPG Game Engine On Web & Android & IOS.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

audioplayers, flutter

More

Packages that depend on devilf_engine