db_navigator 0.1.5 copy "db_navigator: ^0.1.5" to clipboard
db_navigator: ^0.1.5 copied to clipboard

A flutter package that provide easy navigation with navigator 2.0.

6
likes
120/ 140
pub points
40%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

183 out of 185 API elements (98.9 %) have documentation comments.

Some symbols that are missing documentation: db_navigator, db_navigator.DBNestedNavigationForTabBarView.physics.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'location' is deprecated and shouldn't be used. Pass Uri.parse(location) to uri parameter instead. This feature was deprecated after v3.8.0-3.0.pre.

lib/src/db_route_information_parser.dart:27:7

   ╷
27 │       location: configuration.path,
   │       ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/db_route_information_parser.dart

INFO: 'location' is deprecated and shouldn't be used. Use uri instead. This feature was deprecated after v3.8.0-3.0.pre.

lib/src/destination.dart:33:30

   ╷
33 │       path: routeInformation.location,
   │                              ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/destination.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection >=1.15.0 <2.0.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
json_annotation >=4.3.0 <6.2.0 4.9.0 4.9.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

6
likes
120
pub points
40%
popularity

Publisher

unverified uploader

A flutter package that provide easy navigation with navigator 2.0.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

collection, flutter, json_annotation

More

Packages that depend on db_navigator