dashbook 0.1.15 copy "dashbook: ^0.1.15" to clipboard
dashbook: ^0.1.15 copied to clipboard

A showcase/sandbox library to help you build isolated widgets in Flutter

113
likes
140/ 160
pub points
90%
popularity

We analyzed this package 18 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

10 out of 88 API elements (11.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: dashbook, dashbook.CenterDecorator, dashbook.CenterDecorator.CenterDecorator, dashbook.CenterDecorator.decorate, dashbook.Chapter.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
device_frame ^1.1.0 1.2.0 1.2.0
flutter flutter 0.0.0 0.0.0
flutter_colorpicker ^1.1.0 1.1.0 1.1.0
flutter_markdown ^0.6.17+3 0.6.23 0.7.3
shared_preferences ^2.2.1 2.2.3 2.2.3
url_launcher ^6.1.14 6.3.0 6.3.0
web ^0.5.0 0.5.1 1.0.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
freezed_annotation - 2.4.4 2.4.4
json_annotation - 4.9.0 4.9.0
markdown - 7.2.2 7.2.2
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
url_launcher_android - 6.3.4 6.3.4
url_launcher_ios - 6.3.1 6.3.1
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.17+3` on flutter_markdown does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions flutter_markdown to update the constraint.

The constraint `^0.5.0` on web does not support the stable version `1.0.0`, that was published 2 days ago.

When web is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions web to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.