dartssh2_cli 1.0.0 copy "dartssh2_cli: ^1.0.0" to clipboard
dartssh2_cli: ^1.0.0 copied to clipboard

The command-line tools built with dartssh2. Includes dartssh and dartsftp.

2
likes
140/ 160
pub points
15%
popularity

We analyzed this package 5 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 2 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: dartssh2_cli.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.0.0 2.5.0 2.5.0
dart_console ^1.0.0 1.2.0 4.1.0
dartssh2 ^2.7.2 2.8.2 2.8.2
Transitive dependencies
Package Constraint Compatible Latest
asn1lib - 1.5.3 1.5.3
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
ffi - 2.1.2 2.1.2
intl - 0.18.1 0.19.0
js - 0.7.1 0.7.1
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
pinenacl - 0.5.1 0.6.0
pointycastle - 3.9.1 3.9.1
typed_data - 1.3.2 1.3.2
win32 - 5.5.1 5.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on dart_console does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dart_console to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

2
likes
140
pub points
15%
popularity

Publisher

verified publisherterminal.studio

The command-line tools built with dartssh2. Includes dartssh and dartsftp.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, dart_console, dartssh2

More

Packages that depend on dartssh2_cli