dartssh2_cli 1.0.0 copy "dartssh2_cli: ^1.0.0" to clipboard
dartssh2_cli: ^1.0.0 copied to clipboard

The command-line tools built with dartssh2. Includes dartssh and dartsftp.

This repo contains the source code for dartssh and dartsftp command line tools.

Install #

# Install the `dartssh` command.
dart pub global activate dartssh2_cli

# Then use `dartssh` as regular `ssh` command.
dartssh user@example.com

# Example: execute a command on remote host.
dartssh user@example.com ls -al

# Example: connect to a non-standard port.
dartssh user@example.com:<port>

# Transfer files via SFTP.
dartsftp user@example.com

If the dartssh command can't be found after installation, you might need to set up your path.

1
likes
130
pub points
31%
popularity

Publisher

verified publisherterminal.studio

The command-line tools built with dartssh2. Includes dartssh and dartsftp.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, dart_console, dartssh2

More

Packages that depend on dartssh2_cli