dartrofit 1.0.0-alpha01

  • Readme
  • Changelog
  • Example
  • Installing
  • 12

A Retrofit-Like http client base on http

1.0.0-alpha01 #

  • Initial version

example/example.dart

void main(List<String> arguments) async {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dartrofit: ^1.0.0-alpha01

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dartrofit/dartrofit.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
3
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
55
Overall:
Weighted score of the above. [more]
12
Learn more about scoring.

We analyzed this package on May 30, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev

Health issues and suggestions

Fix lib/src/builtin_call_adapters.dart. (-86.65 points)

Analysis of lib/src/builtin_call_adapters.dart failed with 7 errors, including:

line 3 col 8: Target of URI doesn't exist: 'package:async/async.dart'.

line 93 col 31: The name 'CancelableOperation' isn't a type so it can't be used as a type argument.

line 95 col 3: Undefined class 'CancelableOperation'.

line 106 col 12: Undefined class 'CancelableOperation'.

line 111 col 31: The name 'CancelableOperation' isn't a type so it can't be used as a type argument.

Fix lib/src/call.dart. (-57.81 points)

Analysis of lib/src/call.dart failed with 3 errors:

line 7 col 8: Target of URI doesn't exist: 'package:async/async.dart'.

line 34 col 3: Undefined class 'CancelableOperation'.

line 55 col 9: Undefined class 'CancelableOperation'.

Fix lib/src/utils.dart. (-43.75 points)

Analysis of lib/src/utils.dart failed with 2 errors:

line 1 col 8: Target of URI doesn't exist: 'package:analyzer/dart/element/element.dart'.

line 3 col 22: Undefined class 'Element'.

Fix additional 8 files with analysis or formatting issues. (-1 points)

Additional issues in the following files:

  • lib/src/response_body.dart (1 hint)
  • lib/src/service_methods.dart (1 hint)
  • lib/src/annotations/multipart.dart (Run dartfmt to format lib/src/annotations/multipart.dart.)
  • lib/src/annotations/querys.dart (Run dartfmt to format lib/src/annotations/querys.dart.)
  • lib/src/builtin_converters.dart (Run dartfmt to format lib/src/builtin_converters.dart.)
  • lib/src/iterables.dart (Run dartfmt to format lib/src/iterables.dart.)
  • lib/src/request_builder.dart (Run dartfmt to format lib/src/request_builder.dart.)
  • lib/src/request_factory.dart (Run dartfmt to format lib/src/request_factory.dart.)

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
http ^0.12.0+4 0.12.1
Transitive dependencies
charcode 1.1.3
collection 1.14.12
http_parser 3.1.4
meta 1.1.8
path 1.7.0
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
pedantic ^1.8.0 1.9.0
test ^1.6.0