rx support for dartrofit
- Initial version
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: dartrofit_adapter_rx: ^1.0.0-alpha01
2. Install it
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Apr 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.1
- pana: 0.13.6
Health issues and suggestions
Document public APIs. (-1 points)
4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
dartfmt to format
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Package is pre-release. (-5 points)
Pre-release versions should be used with caution; their API can change in breaking ways.
Maintain an example.
None of the files in the package's
example/ directory matches known example patterns.
Common filename patterns include
dartrofit_adapter_rx.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=2.7.0 <3.0.0|