wedzera 0.1.0

  • Readme
  • Changelog
  • Installing
  • 48

Wedzera #

Wedzera is an extension toolkit for Dart, It contains many convenient, functional, and easy-to-use functions.

Libraries #

wedzera.collection #

Iterables is an extension class for Iterable.

Maps is an extension class for Map.

wedzera.core #

Pair represents a generic pair of two values.

Triple represents a triad of values.

Result a discriminated union that encapsulates a successful outcome with a value of type T or a failure with an arbitrary Exception exception.

ErrorAndStacktrace an Object which containing both an error and the corresponding stack trace.

Strings is an extension class for String.

Transformations contains a lot of practical static method for R Function(T) transform.

Predicates contains a lot of practical static method for bool Function(T) predicate.

wedzera.system #

measureTimeMillis executes the given block and returns elapsed time in milliseconds.

measureTimeMicros executes the given block and returns elapsed time in microseconds.

Changelog #

All notable changes to this project will be documented in this file.

[0.1.0] - 2020-03-22 #

Added #

  • Extend a lot of practical methods for Iterable/Map, these methods can make you more convenient for functional programming, such as Iterable#scan, Iterable#groupingBy, Map#getOrPut, etc.

  • Added some map/filter static methods commonly used in functional programming.

  • Extend a lot of practical methods for String, such as String#toIntOrNull, etc.

  • Added Pair/Triple class and added its conversion function to Map(MapEntry)/List.

  • Added Result class.

  • Added ErrorAndStacktrace class.

  • In order to more easily detect the execution time of code blocks, you can use measureTimeMillis() or measureTimeMicros().

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  wedzera: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:wedzera/collection.dart';
import 'package:wedzera/core.dart';
import 'package:wedzera/system.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and wedzera.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
collection ^1.14.12 1.14.13 1.15.0-nullsafety
quiver ^2.1.3 2.1.3
Transitive dependencies
matcher 0.12.9
meta 1.2.2 1.3.0-nullsafety
path 1.7.0
stack_trace 1.9.5
Dev dependencies
benchmark_harness ^1.0.5
pedantic ^1.8.0
test ^1.6.0