dartemis_builder 0.1.1
dartemis_builder: ^0.1.1 copied to clipboard

A builder for use with dartemis to generate code that initializes EntitySystems and Managers.

0
likes
70 / 110
pub points
2 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 8 API elements (12.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dartemis_builder/builder.dart that imports:
  • package:dartemis_builder/system_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.36.0 <0.42.00.41.21.4.0
build^1.0.01.6.22.0.0
build_config>=0.3.0 <0.5.00.4.70.4.7
dartemis^0.8.00.8.00.9.0
source_gen^0.9.00.9.10+31.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.020.0.0
args-2.0.02.0.0
async-2.5.02.5.0
charcode-1.2.01.2.0
checked_yaml-2.0.12.0.1
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
dart_style-1.3.122.0.0
file-6.1.06.1.0
glob-2.0.12.0.1
json_annotation-4.0.14.0.1
logging-1.0.11.0.1
meta-1.3.01.3.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pub_semver-2.0.02.0.0
pubspec_parse-1.0.01.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `>=0.36.0 <0.42.0` on analyzer does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.0.0` on build does not support the stable version `2.0.0`, that was published 26 days ago.

When build is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

0
likes
70
pub points
2%
popularity

A builder for use with dartemis to generate code that initializes EntitySystems and Managers.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

dennis.kaselow@gmail.com

License

MIT (LICENSE)

Dependencies

analyzer, build, build_config, dartemis, source_gen

More

Packages that depend on dartemis_builder