dartemis_builder 0.1.1
dartemis_builder: ^0.1.1 copied to clipboard

A builder for use with dartemis to generate code that initializes EntitySystems and Managers.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add dartemis_builder

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  dartemis_builder: ^0.1.1

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:dartemis_builder/builder.dart';
import 'package:dartemis_builder/system_generator.dart';
0
likes
70
pub points
2%
popularity

A builder for use with dartemis to generate code that initializes EntitySystems and Managers.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

dennis.kaselow@gmail.com

License

MIT (LICENSE)

Dependencies

analyzer, build, build_config, dartemis, source_gen

More

Packages that depend on dartemis_builder