dartdoc 0.36.1

Dart native

A non-interactive HTML documentation generator for Dart source code.

15
likes
90 / 110
pub points
82 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 355 out of 1274 API elements (27.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dartdoc/dartdoc.dart that imports:
  • package:dartdoc/src/package_config_provider.dart that imports:
  • package:package_config/package_config.dart that imports:
  • package:package_config/src/package_config_io.dart that imports:
  • package:package_config/src/util_io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'FeatureSet.fromEnableFlags' is deprecated and shouldn't be used. Use 'fromEnableFlags2' instead.

lib/src/model/package_builder.dart:167:29

    ╷
167 │         ..contextFeatures = FeatureSet.fromEnableFlags(config.enableExperiment);
    │                             ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/model/package_builder.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.40.40.40.40.40.4
args>=1.5.0 <2.0.01.6.01.6.0
cli_util>=0.1.4 <0.3.00.2.00.2.0
collection^1.2.01.14.131.14.13
crypto^2.0.62.1.52.1.5
glob>=1.1.2 <2.0.01.2.01.2.0
html>=0.12.1 <0.15.00.14.0+40.14.0+4
logging^0.11.3+10.11.40.11.4
markdown>=2.1.5 <4.0.03.0.03.0.0
meta^1.1.81.2.31.2.3
mustache^1.1.01.1.11.1.1
package_config>=0.1.5 <2.0.01.9.31.9.3
path^1.3.01.7.01.7.0
pub_semver^1.3.71.4.41.4.4
yaml^2.1.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-11.0.011.0.0
charcode-1.1.31.1.3
convert-2.1.12.1.1
csslib-0.16.20.16.2
js-0.6.20.6.2
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs