dartdoc 0.42.0
dartdoc: ^0.42.0 copied to clipboard

A non-interactive HTML documentation generator for Dart source code.

Use this package as an executable

1. Install it

You can install the package from the command line:

$ dart pub global activate dartdoc

Use it

The package has the following executables:

$ dartdoc

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add dartdoc

With Flutter:

 $ flutter pub pub add dartdoc

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  dartdoc: ^0.42.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:dartdoc/dartdoc.dart';
36
likes
100
pub points
85%
popularity

Publisher

tools.dart.dev

A non-interactive HTML documentation generator for Dart source code.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

analyzer, args, charcode, cli_util, collection, crypto, glob, html, logging, markdown, meta, package_config, path, pub_semver, source_span, yaml

More

Packages that depend on dartdoc