dart_license_plist 1.1.3 copy "dart_license_plist: ^1.1.3" to clipboard
dart_license_plist: ^1.1.3 copied to clipboard

command-line tool to generate a license plist file for the Dart programming language.

1
likes
140/ 160
pub points
5%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

0 out of 0 API elements (100.0 %) have documentation comments.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Linux
  • ✓ macOS
  • ✓ Windows

These platforms are not supported:

Android

Cannot assign Android automatically to a binary only package.

iOS

Cannot assign iOS automatically to a binary only package.

Web

Cannot assign Web automatically to a binary only package.

OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.16.0 1.18.0 1.18.0
html ^0.15.0 0.15.4 0.15.4
http ^0.13.4 0.13.6 1.2.1
interact ^2.1.1 2.2.0 2.2.0
path ^1.8.0 1.9.0 1.9.0
pub_updater ^0.2.2 0.2.4 0.4.0
xml ^5.3.1 5.4.1 6.5.0
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
csslib - 1.0.0 1.0.0
dart_console - 1.2.0 4.1.0
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
http_parser - 4.0.2 4.0.2
intl - 0.18.1 0.19.0
json_annotation - 4.9.0 4.9.0
meta - 1.15.0 1.15.0
petitparser - 5.4.0 6.0.2
platform - 3.1.5 3.1.5
process - 4.2.4 5.0.2
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tint - 2.0.1 2.0.1
typed_data - 1.3.2 1.3.2
win32 - 5.5.1 5.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^0.2.2` on pub_updater does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions pub_updater to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.5, Dart 3.4.1.

Check the analysis log for details.

1
likes
140
pub points
5%
popularity

Publisher

verified publishernomunomu0504.dev

command-line tool to generate a license plist file for the Dart programming language.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, html, http, interact, path, pub_updater, xml, yaml

More

Packages that depend on dart_license_plist