dart_board_canvas 1.3.6 icon indicating copy to clipboard operation
dart_board_canvas: ^1.3.6 copied to clipboard

Animated canvas feature - Use to mount animations to routes

1
likes
110/ 140
pub points
29%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 43 API elements (34.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'dart:ui' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/dart_board_canvas.dart:2:8

  ╷
2 │ import 'dart:ui';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/dart_board_canvas.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dart_board_core^0.9.16+60.9.16+60.9.16+6
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
clock-1.1.11.1.1
collection-1.17.01.17.1
dart_board_widgets-1.9.01.9.0
intl-0.17.00.18.0
js-0.6.50.6.7
logging-1.1.11.1.1
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
path-1.8.31.8.3
sky_engine-0.0.990.0.99
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

1
likes
110
pub points
29%
popularity

Publisher

verified publisher icondart-board.io

Animated canvas feature - Use to mount animations to routes

Homepage

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

dart_board_core, flutter

More

Packages that depend on dart_board_canvas