cramr_ui_lib 3.0.6 copy "cramr_ui_lib: ^3.0.6" to clipboard
cramr_ui_lib: ^3.0.6 copied to clipboard

UI Library for all cramr derrivatives. This library contains all kinds of screens that will help language learners automate their knowledge.

0
likes
110/ 140
pub points
14%
popularity

We analyzed this package 10 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

111 out of 446 API elements (24.9 %) have documentation comments.

Some symbols that are missing documentation: ads_controller, ads_controller.AdsController, ads_controller.AdsController.AdsController, ads_controller.AdsController.androidAdRequest, ads_controller.AdsController.createAdRequest.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 32 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/routes/verb_indicative_evaluate_route.dart:139:36

    ╷
139 │     bool adsEnabled = adsController!.isAdvertisingEnabled;
    │                                    ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/routes/verb_indicative_evaluate_route.dart

WARNING: The '!' will have no effect because the receiver can't be null.

lib/routes/verb_indicative_evaluate_route.dart:162:36

    ╷
162 │     bool adsEnabled = adsController!.isAdvertisingEnabled;
    │                                    ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/routes/verb_indicative_evaluate_route.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
advertising_id ^2.3.0 2.6.0 2.6.0
app_tracking_transparency ^2.0.2+1 2.0.4 2.0.4
cramr_widget_lib ^1.0.0 1.0.1 1.0.1
firebase_core ^2.4.0 2.24.2 2.25.4
firebase_crashlytics ^3.0.7 3.4.9 3.4.15
firebase_messaging ^14.2.0 14.7.10 14.7.16
flutter flutter 0.0.0 0.0.0
flutter_local_notifications ^13.0.0 13.0.0 16.3.2
flutter_native_timezone ^2.0.0 2.0.0 2.0.0
font_awesome_flutter ^10.1.0 10.7.0 10.7.0
google_mobile_ads ^2.0.1 2.4.0 4.0.0
intl ^0.18.0 0.18.1 0.19.0
provider ^6.0.1 6.1.1 6.1.1
shared_preferences ^2.0.11 2.2.2 2.2.2
timezone ^0.9.0 0.9.2 0.9.2
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.16 1.3.22
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
dbus - 0.7.10 0.7.10
fake_async - 1.3.1 1.3.1
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
firebase_core_platform_interface - 5.0.0 5.0.0
firebase_core_web - 2.10.0 2.11.4
firebase_crashlytics_platform_interface - 3.6.16 3.6.22
firebase_messaging_platform_interface - 4.5.18 4.5.24
firebase_messaging_web - 3.5.18 3.6.5
flutter_local_notifications_linux - 3.0.0+1 4.0.0+1
flutter_local_notifications_platform_interface - 6.0.0 7.0.0+1
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
js - 0.6.7 0.7.1
leak_tracker - 10.0.0 10.0.4
leak_tracker_flutter_testing - 2.0.1 3.0.3
leak_tracker_testing - 2.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
process - 4.2.4 5.0.2
shared_preferences_android - 2.2.1 2.2.1
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.0
vector_math - 2.1.4 2.1.4
visibility_detector - 0.3.3 0.4.0+2
vm_service - 13.0.0 14.0.0
web - 0.5.0 0.5.0
win32 - 5.2.0 5.2.0
xdg_directories - 0.2.0+3 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^13.0.0` on flutter_local_notifications does not support the stable version `14.0.0`.

Try running dart pub upgrade --major-versions flutter_local_notifications to update the constraint.

The constraint `^2.0.1` on google_mobile_ads does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions google_mobile_ads to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

0
likes
110
pub points
14%
popularity

Publisher

verified publisherteamwabisabi.be

UI Library for all cramr derrivatives. This library contains all kinds of screens that will help language learners automate their knowledge.

Homepage

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

advertising_id, app_tracking_transparency, cramr_widget_lib, firebase_core, firebase_crashlytics, firebase_messaging, flutter, flutter_local_notifications, flutter_native_timezone, font_awesome_flutter, google_mobile_ads, intl, provider, shared_preferences, timezone

More

Packages that depend on cramr_ui_lib