corekit_im 1.0.0 copy "corekit_im: ^1.0.0" to clipboard
corekit_im: ^1.0.0 copied to clipboard

Core IM components for IM flutter.

0
likes
85/ 140
pub points
2%
popularity

We analyzed this package 6 hours ago, and awarded it 85 pub points (of a possible 140):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: corekit_im,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: corekit_im.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

5 out of 170 API elements (2.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: chat_message, chat_message.ChatMessage.ackCount, chat_message.ChatMessage.fromUser, chat_message.ChatMessage.getNickName, chat_message.ChatMessage.getPinAccId.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:corekit_im/im_kit_client.dart that imports:
  • package:yunxin_alog/yunxin_alog.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:corekit_im/im_kit_client.dart that imports:
  • package:yunxin_alog/yunxin_alog.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:corekit_im/im_kit_client.dart that imports:
  • package:yunxin_alog/yunxin_alog.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:corekit_im/im_kit_client.dart that imports:
  • package:yunxin_alog/yunxin_alog.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'queryMessageList' is deprecated and shouldn't be used. queryMessageListEx.

lib/services/message/message_provider_impl.dart:33:10

   ╷
33 │         .queryMessageList(account, sessionType, limit);
   │          ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/services/message/message_provider_impl.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
crypto ^3.0.2 3.0.3 3.0.3
flutter flutter 0.0.0 0.0.0
get_it ^7.2.0 7.7.0 7.7.0
nim_core ^1.0.11 1.7.2 1.7.7
path_provider ^2.0.11 2.1.3 2.1.3
shared_preferences ^2.0.15 2.2.3 2.2.3
yunxin_alog ^1.0.7 1.0.11 2.0.0
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.0 3.6.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
hawk_meta - 0.0.1 0.0.1
json_annotation - 4.9.0 4.9.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
nim_core_macos - 1.0.8 1.0.8
nim_core_platform_interface - 1.7.7 1.7.7
nim_core_web - 1.0.2 1.0.2
nim_core_windows - 1.0.8 1.0.8
path - 1.9.0 1.9.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
process_run - 0.12.5+3 0.14.2
pub_semver - 2.1.4 2.1.4
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
universal_io - 2.2.2 2.2.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.7` on yunxin_alog does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions yunxin_alog to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.