ck_utils 1.0.3 copy "ck_utils: ^1.0.3" to clipboard
ck_utils: ^1.0.3 copied to clipboard

Collection of Widgets and helpful Methods

2
likes
100/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

189 out of 581 API elements (32.5 %) have documentation comments.

Some symbols that are missing documentation: app_textfield, app_textfield.AppTextField.autoFillHints, app_textfield.AppTextField.autoFocus, app_textfield.AppTextField.buildCounter, app_textfield.AppTextField.controller.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ck_utils/ck_utils.dart that imports:
  • package:ck_utils/all_src/utils/common.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:ck_utils/ck_utils.dart that imports:
  • package:ck_utils/all_src/utils/common.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:ck_utils/ck_utils.dart that imports:
  • package:ck_utils/all_src/utils/common.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package not compatible with platform Web

Because:

  • package:ck_utils/ck_utils.dart that imports:
  • package:ck_utils/all_src/utils/common.dart that imports:
  • package:ck_utils/all_src/extensions_validation/device_extensions.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 25 issues. Showing the first 2:

INFO: The type name 'introScreenModelClass' isn't an UpperCamelCase identifier.

lib/all_src/basic_app_model/introscreen.dart:3:7

  ╷
3 │ class introScreenModelClass {
  │       ^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/all_src/basic_app_model/introscreen.dart

INFO: Use 'isNotEmpty' instead of 'length' to test whether the collection is empty.

lib/all_src/extensions_validation/string_extensions.dart:35:38

   ╷
35 │   String capitalizeFirstLetter() => (validate().length >= 1)
   │                                      ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/all_src/extensions_validation/string_extensions.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
connectivity_plus ^2.3.6+1 2.3.9 6.0.2
flutter flutter 0.0.0 0.0.0
fluttertoast ^8.0.9 8.2.5 8.2.5
shared_preferences ^2.0.15 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
connectivity_plus_linux - 1.3.1 1.3.1
connectivity_plus_macos - 1.2.6 1.2.6
connectivity_plus_platform_interface - 1.2.4 2.0.0
connectivity_plus_web - 1.2.5 1.2.5
connectivity_plus_windows - 1.2.2 1.2.2
dbus - 0.7.10 0.7.10
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nm - 0.5.0 0.5.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.3.6+1` on connectivity_plus does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

2
likes
100
pub points
0%
popularity

Publisher

unverified uploader

Collection of Widgets and helpful Methods

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

connectivity_plus, flutter, fluttertoast, shared_preferences

More

Packages that depend on ck_utils