cherry 0.0.1-alpha copy "cherry: ^0.0.1-alpha" to clipboard
cherry: ^0.0.1-alpha copied to clipboard

Dart CLI template generator and package manager for flutter, generate MVC, MVVM and MVU patterns.

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 100 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

31 out of 54 API elements (57.4 %) have documentation comments.

Some symbols that are missing documentation: cherry, cherry.BaseCommand, cherry.BaseCommand.BaseCommand, cherry.BaseCommand.invocationSuffix, cherry.Create.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:cherry/cherry.dart that imports:
  • package:cherry/src/command/start/start_command.dart that imports:
  • package:cherry/src/command/start/start.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:cherry/cherry.dart that imports:
  • package:cherry/src/command/start/start_command.dart that imports:
  • package:cherry/src/command/start/start.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:cherry/cherry.dart that imports:
  • package:cherry/src/command/start/start_command.dart that imports:
  • package:cherry/src/command/start/start.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Linux`.

Because:

  • package:cherry/cherry.dart that imports:
  • package:cherry/src/command/start/start_command.dart that imports:
  • package:cherry/src/command/start/start.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:cherry/cherry.dart that imports:
  • package:cherry/src/command/start/start_command.dart that imports:
  • package:cherry/src/command/start/start.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

WARNING: Unused import: 'package:args/command_runner.dart'.

lib/src/command/generate/generate_command.dart:1:8

  ╷
1 │ import 'package:args/command_runner.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/command/generate/generate_command.dart

INFO: The import of 'package:cherry/src/command/create/create_command.dart' is unnecessary because all of the used elements are also provided by the import of 'package:cherry/cherry.dart'.

bin/cherry.dart:4:8

  ╷
4 │ import 'package:cherry/src/command/create/create_command.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze bin/cherry.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ansicolor ^2.0.0-nullsafety.0 2.0.2 2.0.2
args ^2.0.0 2.4.2 2.4.2
dart_console ^1.0.0 1.2.0 1.2.0
http ^0.13.1 0.13.6 1.2.1
path ^1.8.0 1.9.0 1.9.0
tuple ^2.0.0-nullsafety.0 2.0.2 2.0.2
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
http_parser - 4.0.2 4.0.2
intl - 0.18.1 0.19.0
meta - 1.12.0 1.12.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
win32 - 5.2.0 5.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.1` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

0
likes
100
pub points
0%
popularity

Publisher

verified publishersameerkashyap.me

Dart CLI template generator and package manager for flutter, generate MVC, MVVM and MVU patterns.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ansicolor, args, dart_console, http, path, tuple, yaml

More

Packages that depend on cherry