cens4k_nfc 1.0.45 copy "cens4k_nfc: ^1.0.45" to clipboard
cens4k_nfc: ^1.0.45 copied to clipboard

PlatformAndroid

Nfc library for dispower pay as you go, libreria nfc para sistemas prepago de energia DISPOWER. SUPPORT ANDROID V2

0
likes
80/ 140
pub points
0%
popularity

We analyzed this package 21 hours ago, and awarded it 80 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 35 API elements (2.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: cens4k_nfc, cens4k_nfc.Engenius, cens4k_nfc.Engenius.Engenius, cens4k_nfc.Engenius.channel, cens4k_nfc.Engenius.habilitar.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:cens4k_nfc/engenius.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:cens4k_nfc/engenius.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:cens4k_nfc/engenius.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:cens4k_nfc/engenius.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:cens4k_nfc/engenius.dart that declares support for platforms: Android.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'false'.

lib/engenius.dart:408:43

    ╷
408 │         } else if (serial == [] || serial == null) {
    │                                           ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/engenius.dart

INFO: The variable name 'card_id' isn't a lowerCamelCase identifier.

lib/engenius.dart:39:11

   ╷
39 │ Uint8List card_id = Uint8List.fromList([69, 88, 67, 69, 76, 69]);
   │           ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/engenius.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
encrypt ^5.0.1 5.0.3 5.0.3
flutter flutter 0.0.0 0.0.0
http ^0.13.3 0.13.6 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
pointycastle - 3.9.1 3.9.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

0
likes
80
pub points
0%
popularity

Publisher

verified publishersuncoenergy.com.co

Nfc library for dispower pay as you go, libreria nfc para sistemas prepago de energia DISPOWER. SUPPORT ANDROID V2

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

encrypt, flutter, http

More

Packages that depend on cens4k_nfc