cbl_dart 3.0.1 copy "cbl_dart: ^3.0.1" to clipboard
cbl_dart: ^3.0.1 copied to clipboard

Couchbase Lite for pure Dart apps: An embedded, NoSQL JSON Document Style database, supporting Blobs, Encryption, SQL++ Queries, Live Queries, Full-Text Search and Data Sync.

7
likes
160/ 160
pub points
84%
popularity

We analyzed this package 4 days ago, and awarded it 160 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/cbl-dart/cbl-dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 5 API elements (80.0 %) have documentation comments.

Some symbols that are missing documentation: cbl_dart.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:cbl_dart/cbl_dart.dart that imports:
  • package:cbl_dart/src/package.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
archive ^3.5.0 3.6.1 3.6.1
cbl ^3.0.0 3.0.0 3.0.0
cbl_libcblite_api 3.1.6 3.1.6 3.1.6
cbl_libcblitedart_api 7.1.0 7.1.0 7.1.0
crypto ^3.0.1 3.0.3 3.0.3
http ^1.0.0 1.2.1 1.2.1
logging ^1.1.0 1.2.0 1.2.0
path ^1.8.0 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.19.0 1.19.0
ffi - 2.1.2 2.1.2
http_parser - 4.1.0 4.1.0
meta - 1.15.0 1.15.0
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

7
likes
160
pub points
84%
popularity

Publisher

verified publishercbl-dart.dev

Couchbase Lite for pure Dart apps: An embedded, NoSQL JSON Document Style database, supporting Blobs, Encryption, SQL++ Queries, Live Queries, Full-Text Search and Data Sync.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

archive, cbl, cbl_libcblite_api, cbl_libcblitedart_api, crypto, http, logging, path

More

Packages that depend on cbl_dart