cbl_dart 3.0.1 copy "cbl_dart: ^3.0.1" to clipboard
cbl_dart: ^3.0.1 copied to clipboard

Couchbase Lite for pure Dart apps: An embedded, NoSQL JSON Document Style database, supporting Blobs, Encryption, SQL++ Queries, Live Queries, Full-Text Search and Data Sync.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add cbl_dart

With Flutter:

 $ flutter pub add cbl_dart

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  cbl_dart: ^3.0.1

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:cbl_dart/cbl_dart.dart';
7
likes
160
pub points
84%
popularity

Publisher

verified publishercbl-dart.dev

Couchbase Lite for pure Dart apps: An embedded, NoSQL JSON Document Style database, supporting Blobs, Encryption, SQL++ Queries, Live Queries, Full-Text Search and Data Sync.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

archive, cbl, cbl_libcblite_api, cbl_libcblitedart_api, crypto, http, logging, path

More

Packages that depend on cbl_dart