built_value_generator 7.1.0
built_value_generator: ^7.1.0

Dart native

Value types with builders, Dart classes as enums, and serialization. This library is the dev dependency.

59
likes
90 / 110
pub points
92 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 6 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:built_value_generator/built_value_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.39.3 <0.40.00.39.170.41.0
build^1.0.01.5.11.5.1
build_config>=0.3.1 <0.5.00.4.30.4.3
built_collection>=2.0.0 <5.0.04.3.24.3.2
built_value>=7.0.0 <7.2.07.1.07.1.0
quiver>=0.21.0 <3.0.02.1.52.1.5
source_gen^0.9.00.9.80.9.8
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.013.0.0
args-1.6.01.6.0
async-2.4.22.4.2
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.61.3.10
file-5.2.15.2.1
fixnum-0.10.110.10.11
glob-1.2.01.2.0
html-0.14.0+40.14.0+4
intl-0.16.10.16.1
js-0.6.20.6.2
json_annotation-3.1.13.1.1
matcher-0.12.90.12.9
meta-1.2.41.2.4
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
path-1.7.01.7.0
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.39.3 <0.40.0` on analyzer does not support the latest published version `0.41.0`

pubspec.yaml:12:13

   ╷
12 │   analyzer: '>=0.39.3 <0.40.0'
   │             ^^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

59
likes
90
pub points
92%
popularity

Publisher

dart.dev

Value types with builders, Dart classes as enums, and serialization. This library is the dev dependency.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

analyzer, build, build_config, built_collection, built_value, quiver, source_gen

More

Packages that depend on built_value_generator