brick_offline_first 1.1.0
brick_offline_first: ^1.1.0 copied to clipboard

A Brick domain that routes data fetching through local providers before remote providers.

53
likes
110/ 130
pub points
66%
popularity

We analyzed this package 24 hours ago, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 57 out of 85 API elements (67.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:brick_offline_first/mixins.dart that imports:
  • package:brick_offline_first/src/mixins/destructive_local_sync_from_remote_mixin.dart that imports:
  • package:brick_offline_first/offline_first.dart that imports:
  • package:brick_offline_first/src/offline_first_repository.dart that imports:
  • package:brick_sqlite/sqlite.dart that imports:
  • package:brick_sqlite/src/sqlite_provider.dart that imports:
  • package:brick_sqlite/src/sqlite_model_dictionary.dart that imports:
  • package:brick_sqlite/src/sqlite_adapter.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

lib/rest_to_offline_first_converter.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/mixins/destructive_local_sync_from_remote_mixin.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
brick_core^1.0.0+11.0.0+11.0.0+1
brick_offline_first_abstract^1.0.0+11.0.0+11.0.0+1
brick_rest^1.1.01.1.01.1.0
brick_sqlite^1.1.01.1.01.1.0
brick_sqlite_abstract^1.0.0+31.0.0+31.0.0+3
collection^1.15.01.15.01.15.0
dart_style^2.0.02.2.02.2.0
http^0.13.00.13.40.13.4
logging^1.0.01.0.21.0.2
meta^1.3.01.7.01.7.0
path^1.8.01.8.01.8.0
sqflite^2.0.0+12.0.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-31.0.031.0.0
analyzer-2.8.02.8.0
args-2.3.02.3.0
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-6.1.26.1.2
flutter-0.0.00.0.0
glob-2.0.22.0.2
http_parser-4.0.04.0.0
package_config-2.0.22.0.2
pub_semver-2.1.02.1.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.