brick_offline_first 3.2.0 copy "brick_offline_first: ^3.2.0" to clipboard
brick_offline_first: ^3.2.0 copied to clipboard

A Brick domain that routes data fetching through local providers before remote providers.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add brick_offline_first

With Flutter:

 $ flutter pub add brick_offline_first

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  brick_offline_first: ^3.2.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:brick_offline_first/brick_offline_first.dart';
81
likes
120
pub points
64%
popularity

Publisher

unverified uploader

A Brick domain that routes data fetching through local providers before remote providers.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

brick_core, brick_sqlite, collection, dart_style, http, logging, meta, path, sqflite_common

More

Packages that depend on brick_offline_first