brcontent 2.0.0 copy "brcontent: ^2.0.0" to clipboard
brcontent: ^2.0.0 copied to clipboard

Bloomreach Content Flutter SDK - Features a Dart Page Delivery API Client

2
likes
130/ 160
pub points
25%
popularity

We analyzed this package 6 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

66 out of 253 API elements (26.1 %) have documentation comments.

Some symbols that are missing documentation: pda.content.bloomreach, pda.content.bloomreach.AbstractComponent, pda.content.bloomreach.AbstractComponent.id, pda.content.bloomreach.AbstractComponent.label, pda.content.bloomreach.AbstractComponent.name.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:brcontent/api.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 52 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'false'.

lib/api_helper.dart:71:26

   ╷
71 │     ? response.bodyBytes == null ? null : utf8.decode(response.bodyBytes)
   │                          ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/api_helper.dart

WARNING: The operand can't be null, so the condition is always 'false'.

lib/model/data.dart:28:11

   ╷
28 │     (data == null ? 0 : data.hashCode);
   │           ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/model/data.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.17.0 1.19.0 1.19.0
http ^1.1.0 1.2.2 1.2.2
intl ^0.18.0 0.18.1 0.19.0
meta ^1.1.8 1.15.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
clock - 1.1.1 1.1.1
http_parser - 4.1.0 4.1.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 1.0.0 1.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.18.0` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

2
likes
130
pub points
25%
popularity

Publisher

verified publisherpub.bloomreach.works

Bloomreach Content Flutter SDK - Features a Dart Page Delivery API Client

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (license)

Dependencies

collection, http, intl, meta

More

Packages that depend on brcontent